Mehr

Kann GeoEXT 2.0 mit ExtJS 5.0 verwendet werden?


Ich habe mir gerade Ext 5.0 angesehen, das einige Änderungen enthält. Ich frage mich, ob es mit GeoExt 2.0 kompatibel ist. Es scheint Probleme mit GeoExt.Popup zu geben


Nein, GeoExt 2.0.2 (https://github.com/geoext/geoext2/releases/tag/v2.0.2, veröffentlicht vor zwei Tagen) ist nicht mit ExtJS 5 kompatibel.

Es wird laufend an einer Version von GeoExt2 gearbeitet, die ExtJS 5 unterstützt: https://github.com/geoext/geoext2/pull/274

Möglicherweise können Sie den Zwischencode in diesem Zweig verwenden, um zu sehen, ob er beim Popup hilft, aber auch hier ist er noch nicht offiziell veröffentlicht.


Schau das Video: Ext JS Development in Visual Studio Code (Oktober 2021).